December 3rd, 2012 Add Your Comments

delete: /Applications/MAMP/bin/php/php5.4.4/conf/pear.conf
(delete or bak)

$ /Applications/MAMP/bin/php/php5.4.4/bin/pear channel-update pear.php.net
$ /Applications/MAMP/bin/php/php5.4.4/bin/pear upgrade pear
$ /Applications/MAMP/bin/php/php5.4.4/bin/pear channel-discover pear.phpunit.de
$ /Applications/MAMP/bin/php/php5.4.4/bin/pear channel-discover pear.symfony-project.com
$ /Applications/MAMP/bin/php/php5.4.4/bin/pear install phpunit/PHPUnit

make available in terminal:
$ mv /Applications/MAMP/bin/php/php5.4.4/bin/phpunit /usr/local/bin/phpunit

test:
type phpunit –version in Terminal
(you will see latest version of PHPUnit).

Note, if you need an older version of PHPUnit, like 3.6.x, you will indicate that when installing phpunit/PHPUnit-3.6.12